IIS 6 + AJAX + Create User Fail on first

Aug 15, 2008 at 2:03 PM
Edited Aug 15, 2008 at 2:03 PM
Hello,

This is a great control. For some reason though, it fails on the first check when creating a user.
It works on the second attempt usually.

The setup is:
The control is version 2.0 Beta.
The control is in a templated create user control, which all is located in an AJAX Update panel.
IIS 6
Using Session
Timeouts are set to 5000 for request timeout and validation timeout.

    <autoInputProtection persistenceMode="Session" defaultTextProvider="random text" defaultImageProvider="resource">       
        <textProviders>
            <add name="random text" minimumCharacters="3" maximumCharacters="4"
                 type="DaveSexton.Web.Controls.RandomCharactersAutoInputProtectionTextProvider, DaveSexton.AutoInputProtection"
                 colors="Red,Green,Blue,Brown" fonts="Times New Roman,Arial" caseSensitive="false"
                 minimumFontSize="30" maximumFontSize="35" />
        </textProviders>
        <imageProviders>
            <add name="resource"
                 type="DaveSexton.Web.Controls.ResourceAutoInputProtectionImageProvider, DaveSexton.AutoInputProtection"
                 minimumCharacterRotation="-15" maximumCharacterRotation="15" />
        </imageProviders>
    </autoInputProtection>

Thank you
Coordinator
Aug 15, 2008 at 8:18 PM
Hi, 

The configuration appears to be fine.  Are you also using the AutoInputProtectionSessionRequestHandler in the httpHandler registration?

- Dave